import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "5002(?!H)";
final String string = "/?wkz=5002\n"
+ "/?wkz=5002HA-M\n"
+ "/?wkz=5002HB \n"
+ "/?wkz=5002HB-M\n"
+ "/?wkz=5002HF \n"
+ "/?wkz=5002HF-M";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}