import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=by )((\\w+) (\\w+))(?:,\\s*)?((\\w+) (\\w+))?(?:\\s*(?<=and ))((\\w+) (\\w+))";
final String string = "By Person One, Person Two and Person Three\n"
+ "By Person One, Person Two\n"
+ "By Person One\n"
+ "By Person Two and Person Three\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}