const regex = /(?<=by )((\w+) (\w+))(?:,\s*)?((\w+) (\w+))?(?:\s*(?<=and ))((\w+) (\w+))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=by )((\\w+) (\\w+))(?:,\\s*)?((\\w+) (\\w+))?(?:\\s*(?<=and ))((\\w+) (\\w+))', 'gmi')
const str = `By Person One, Person Two and Person Three
By Person One, Person Two
By Person One
By Person Two and Person Three
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}