re = /(?<=by )((\w+) (\w+))(?:,\s*)?((\w+) (\w+))?(?:\s*(?<=and ))((\w+) (\w+))/mi
str = 'By Person One, Person Two and Person Three
By Person One, Person Two
By Person One
By Person Two and Person Three
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end