re = / +$/m
str = ' first line... abc
second is here... def
//<-- blank space here
fourth line... hi there
sith is here.... '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end