const regex = /^(?:(?:\w+)(?:\[(?:\d*|'[^']*')\])*=[\w\-\+\.%]*(?:&|$))+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\w+)(?:\\[(?:\\d*|\'[^\']*\')\\])*=[\\w\\-\\+\\.%]*(?:&|$))+$', 'gm')
const str = `hello=value&am=i
hellp
help=me
pleas=help&me=plz&var[]=true
pleas=&me=&var[]=
helo&ewepcmwep&lalal=true
pleas=help&me=plz&var[]=true&var[2]=false&var['blahblah']=ipsum
pleas=help&me=plz&var[][][]['λαλαλα']=true&var[2]=false&var['blahblah']=ipsum
pleas=ContentDisposition%3A%20formdata%3B%20name%3D%22myfile%22%3B%20filename%3D%22exclude.txt%22&me=plz&var[]=true&var[2]=false&var['blahblah']=ipsum`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}