import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "\\s(?:(?:\\w+::)*(\\w+)(?:<[\\w, ]+>){0,1}::){0,1}(\\w+)[(]";
        final String string = "void rmdt::Worker<T_Channel, T_TransportControl>::setOption(rmdt::SockOpt, int64_t) [with T_Channel = iptransport::udp::Socket; T_TransportControl = rmdt::AggressiveTransportControl; int64_t = long int]\n\n"
	 + "std::error_code rmdt::ReceiveHandler<T_Channel>::internalRunSenderPart(int32_t) [with T_Channel = iptransport::udp::Socket; int32_t = int]\n\n"
	 + "void dex::rmdt::Worker::setOption(rmdt::SockOpt, int64_t)\n\n"
	 + "void Worker::setOption(rmdt::SockOpt, int64_t)\n\n"
	 + "std::pair <HandshakeRequestPayload,int64_t> rmdt::HandshakeAcceptor<T_Channel, T_Val>::receiveHandshake(int)\n\n"
	 + "std::vector<std::__cxx11::basic_string<char> > rmdt::Worker<T_Channel, T_TransportControl>::connect() [with T_Channel = iptransport::udp::Socket; T_TransportControl = rmdt::BQLLP] \n\n"
	 + "dex::type dex::func(int d)\n\n"
	 + "void func(int d)";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}