import Foundation
let pattern = #"\s(?:(?:\w+::)*(\w+)(?:<[\w, ]+>){0,1}::){0,1}(\w+)[(]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
void rmdt::Worker<T_Channel, T_TransportControl>::setOption(rmdt::SockOpt, int64_t) [with T_Channel = iptransport::udp::Socket; T_TransportControl = rmdt::AggressiveTransportControl; int64_t = long int]
std::error_code rmdt::ReceiveHandler<T_Channel>::internalRunSenderPart(int32_t) [with T_Channel = iptransport::udp::Socket; int32_t = int]
void dex::rmdt::Worker::setOption(rmdt::SockOpt, int64_t)
void Worker::setOption(rmdt::SockOpt, int64_t)
std::pair <HandshakeRequestPayload,int64_t> rmdt::HandshakeAcceptor<T_Channel, T_Val>::receiveHandshake(int)
std::vector<std::__cxx11::basic_string<char> > rmdt::Worker<T_Channel, T_TransportControl>::connect() [with T_Channel = iptransport::udp::Socket; T_TransportControl = rmdt::BQLLP]
dex::type dex::func(int d)
void func(int d)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)