using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+Fixed version\s+:\s+(?<FixedVersion>[^\n\r\<]+)";
string input = @"<plugin_output>
Path : C:\Program Files\VMware\VMware Tools\VMware VGAuth\libssl-3-x64.dll
Reported version : 3.0.3.0
Fixed version : 3.0.4</plugin_output>
<plugin_output>
Path : C:\myPrograms\cygwin64\bin\openssl.exe
Reported version : 1.1.1.4
Fixed version : 1.1.1p
Path : C:\myPrograms\Git\usr\bin\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
Path : C:\myPrograms\Git\mingw64\bin\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
</plugin_output>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}