const regex = /\s+Fixed version\s+:\s+(?<FixedVersion>[^\n\r\<]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+Fixed version\\s+:\\s+(?<FixedVersion>[^\\n\\r\\<]+)', 'gm')
const str = `<plugin_output>
Path : C:\\Program Files\\VMware\\VMware Tools\\VMware VGAuth\\libssl-3-x64.dll
Reported version : 3.0.3.0
Fixed version : 3.0.4</plugin_output>
<plugin_output>
Path : C:\\myPrograms\\cygwin64\\bin\\openssl.exe
Reported version : 1.1.1.4
Fixed version : 1.1.1p
Path : C:\\myPrograms\\Git\\usr\\bin\\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
Path : C:\\myPrograms\\Git\\mingw64\\bin\\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
</plugin_output>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}