// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ims)<div\sclass=\"sg-text\">(.*?)<\/div>"#).unwrap();
let string = "<div class=\"brn-answer__content sg-content-box__content\">
<div class=\"sg-content-box sg-content-box--spaced-bottom\">
<div class=\"brn-answer__text\">
<div class=\"sg-text\">
Тут немного текста
</div>
</div>
<div class=\"brn-attachments brn-attachments--spaced-top\">
<a href=\"https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg\" class=\"brn-attachments__attachment\" target=\"_blank\">
<div class=\"sg-box sg-box--image-wrapper \">
<img class=\"sg-box__image\" src=\"https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg\" title=\"Photo\" alt=\"\">
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}