package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{(?<nested>[^{}]+\{[^{}]+\}[^{}]+)\}`)
var str = `\section{Welcome to $\mathbb{R}^n$} \textbf{Other text} \textbf{Other text} \textbf{Other text} \textbf{Other text} \section{Welcome to $\mathbb{R}^n$} \textbf{Other text}\section{Welcome to $\mathbb{R}^n$} \textbf{Other text} \textbf{Other text} \textbf{Other text} \textbf{Other text} \section{Welcome to $\mathbb{R}^n$} \textbf{Other text}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}