import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?<nested>[^\\{\\}]+\\{[^\\{\\}]+\\}[^\\{\\}]+)\\}";
final String string = "\\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text}\\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}