re = /\{(?<nested>[^{}]+\{[^{}]+\}[^{}]+)\}/
str = '\\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text}\\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end