package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\+56|56)?(?:\s?\(?9\)?[\s.-]?(\d{4})[\s.-]?(\d{4}))$`)
var str = `912345678
+56912345678
56912345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}