# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/\d{8}(?=\/)//g;t' <<< "2017/07/24204301/a-4.png
2017/07/24204318/a-5-e1501986401369.png
2017/11/24211223/questao10branca-172x300.png"