#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "/\d{8}(?=/)"
Local $sString = "2017/07/24204301/a-4.png" & @CRLF & _
"2017/07/24204318/a-5-e1501986401369.png" & @CRLF & _
"2017/11/24211223/questao10branca-172x300.png"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)