re = /\/\d{8}(?=\/)/
str = '2017/07/24204301/a-4.png
2017/07/24204318/a-5-e1501986401369.png
2017/11/24211223/questao10branca-172x300.png'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result