const regex = /b\/\*?[\u4e00-\u9fa5a-zA-Z]+\**$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('b\\\/\\*?[\\u4e00-\\u9fa5a-zA-Z]+\\**$', 'gm')
const str = `b/王小明
b/Mr王
b/王小明*
b/王小*
b/*王小
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}