import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?msx) \n"
+ "(^http:\\/\\/www\\. .+$) \n"
+ "(?= .* \\1) ";
final String string = "http://www.link1.com\n"
+ "http://www.link2.com\n"
+ "http://www.link3.com\n"
+ "http://www.link4.com\n"
+ "http://www.link1.com\n"
+ "http://www.link2.com\n"
+ "http://www.link4.com\n"
+ "http://www.link4.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}