$re = '/(?msx)
(^http:\/\/www\. .+$)
(?= .* \1) /';
$str = 'http://www.link1.com
http://www.link2.com
http://www.link3.com
http://www.link4.com
http://www.link1.com
http://www.link2.com
http://www.link4.com
http://www.link4.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);