re = /<div class="article">(.+?)^<\/div>/m
str = '<div class="article">
<p class="title">Test!</p>
<div>Content content</div>
<p>test test</p>
<div class="test">test</div>
<p>test</p>
</div>
<?= rand(0,100); ?>
<div class="article">
<p class="title">Test1!</p>
<div>Content content1</div>
<p>test test1</p>
<div class="test">test1</div>
<p>test1</p>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end