$re = '/^((?!foo).)+$/m';
$str = 'foo lkjlkj
bar
oof
fof
thidls foo dflaksjdf
thasdfd
asdfasd
sd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);