#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*Function=\"([^\"]*).*"
Local $sString = "[1] ID=Gfo_R000001;Source=ENST00000513418;Function="SMAD5"; " & @CRLF & _
"[2] ID=Gfo_R000002;Source=ENSTGUT00000017468;Function="CENPA";" & @CRLF & _
"[3] ID=Gfo_R000003;Source=ENSGALT00000028134;Function="C1QL4";" & @CRLF & _
"[4] ID=Gfo_R000004;Source=ENSTGUT00000015300;Function=""; " & @CRLF & _
"[5] ID=Gfo_R000005;Source=ENSTGUT00000019268;Function=""; " & @CRLF & _
"[6] ID=Gfo_R000006;Source=ENSTGUT00000019035;Function=""; " & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)