import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "step.+\\s+script: \\\".*blr/(.*).py\\\"\\s+.*\\s+args: \\[([\\\"\\w\\W\\s]+?)\\]\\n";
final String string = "step1:\n"
+ " script: \"/workspace/feature-test-lib/tests/upgrade_blr/BQT.py\"\n"
+ " skip: 0\n"
+ " args: [\"testbed\"]\n"
+ " \n"
+ "step2:\n"
+ " script: \"/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py\"\n"
+ " skip: 0\n"
+ " args: [\"testbed\", \"dcinit\"]\n"
+ " \n"
+ "step3:\n"
+ " script: \"/workspace/feature-test-lib/tests/upgrade_blr/sensor_upgrade.py\"\n"
+ " skip: 0\n"
+ " args: [\"testbed\", \"upgrade\"]\n"
+ " \n"
+ "step4:\n"
+ " script: \"/workspace/feature-test-lib/tests/upgrade_blr/Apply_Policy.py\"\n"
+ " skip: 0\n"
+ " args: [\"testbed\"]\n"
+ " \n"
+ "step5:\n"
+ " script: \"/workspace/feature-test-lib/tests/upgrade_blr/sensor_checks.py\"\n"
+ " skip: 0\n"
+ " args: [\"testbed\"]\n"
+ " \n"
+ "step6:\n"
+ " script: \"/workspace/feature-test-lib/tests/upgrade_blr/delete_device.py\"\n"
+ " skip: 0\n"
+ " args: [\"testbed\", \"dcinit\"]\n"
+ " \n"
+ "step7:\n"
+ " script: \"/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py\"\n"
+ " skip: 0\n"
+ " args: [\"testbed\", \"dcinit\"]\n";
final String subst = "\\1, \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}