const regex = /.*?(\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(\\w+)$', 'gm')
const str = `Tommy Hilfiger Men Teal Blue Analogue Watch TH1791293_BBD`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);