$re = '/.*?(\w+)$/m';
$str = 'Tommy Hilfiger Men Teal Blue Analogue Watch TH1791293_BBD';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;