re = /^[^+@]+@\S+$/m
str = 'abc@xyz.com
abc123@xyz.com
abc.def@xyz.com
abc+123@xyz.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end