const regex = /^(?i)(https?:\/\/)?(www\.)?facebook\.com\/group(s)?(\/?\/\d+)?(\/.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?i)(https?:\\\/\\\/)?(www\\.)?facebook\\.com\\\/group(s)?(\\\/?\\\/\\d+)?(\\\/.*)?$', 'gm')
const str = `Https://wWw.facebook.Com/GROUpS/2233223616820715
httpS://Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
https://www.facebook.com/groups/ukrainianenglishclubrachk21312Y
https://www.facebook.com/groups/ukrainianenglishclubrachky/events/fd
Http://wWw.facebook.Com/GROUpS/hhGGGh/22332
http://Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
httP://www.facebook.com/groups/ukrainianenglishclubrachk21312Y
http://www.facebook.com/groups/ukrainianenglishclubrachky/events/fd
wWw.facebook.Com/GROUpS/2233223616820715
Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
www.facebook.com/groups/ukrainianenglishclubrachk21312Y
www.facebook.com/groups/ukrainianenglishclubrachky/events/fd
facebook.Com/GROUpS/2233223616820715
FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
facebook.com/group/ukrainianenglishclubrachk21312Y
facebook.com/groups/ukrainianenglishclubrachky/events/fd
https://www.facebook.com/GROUPS/2233223616820715/?hoisted_section_header_type=recently_seen&multi_permalinks=2744661819010223
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}