const regex = /^\d+(?:\.$|\.\d+)?[KkMm]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(?:\\.$|\\.\\d+)?[KkMm]?$', 'gm')
const str = `400k
400.2k
4m
500000
500.
500.k
4.2.k
.3k
4...k
500k
500.
5.k`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}