re = /([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+/m
str = 'Шизофрений Шизофрениевич Шизофрениев'
subst = '\\1 \\2 \\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result