const regex = /(\[|\]|,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[|\\]|,)', 'gm')
const str = `[33.864423279999997, -84.184913890000004]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);