import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\")([^\"]*)(\")|(')([^']*)(')";
final String string = "\"com s'ha fet?\" 'El \"milor\" que es pot!'";
final String subst = "\\2\\n\\5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}