using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)^.*?number:\s([a-zA-Z0-9]+)";
string substitution = @"";
string input = @"Today's serial is number: A12345
Today's serial is number: A12345";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}