re = /(^|[^@\w])@(\w{1,30})\b(?!.*<\/span>)/
str = '@name
email@website.com
a@b
@thisreallylongstringthatshouldntbematched
<span>@name</span>
<span class="mention">@test</span> @test2
<span></span> @betweentwospans <span></span>
'
subst = '$1<span class="mention">@$2</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result