import Foundation
let pattern = #"(^|[^@\w])@(\w{1,30})\b(?!.*<\/span>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@name
email@website.com
a@b
@thisreallylongstringthatshouldntbematched
<span>@name</span>
<span class="mention">@test</span> @test2
<span></span> @betweentwospans <span></span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<span class="mention">@$2</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)