$re = '/^
(?= (\d+) \1+ (\d*) $ )
(?<pattern> \d+? ) \3+
(?! .+ \2 $)
(?= (?<trailing> \d* ) )/mx';
$str = '14285714285714
7575757
55555555
55555556
15551555
55515551';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);