import Foundation
let pattern = #"-(?:[AR](?:-(?:OK|NG))?|W|C)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Word1-A-OK
Word2-Sample-R-OK
Word3-A
Word1-R
Word2-Sample-A-NG
Word3-R-NG
Word1-W
Word2-Sample-C
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)