$re = '/[+-]?((\d+\.?\d*)|(\.\d+))/m';
$str = '+123.13
-0.464
13115313
000013134
123...
10..12113';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);