$re = '/^(\d+[\+\-\*\/]{1})+\d+$/m';
$str = '5+6+9
4*9+7-8
45++6*6
12+4+
+2-6
2-6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);