$re = '/[a-z]++(?<!lag|pctrange|max)/m';
$str = 'lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);