re = /[a-z]++(?<!lag|pctrange|max)/m
str = 'lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end