#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^$|^[а-яёА-ЯЁ\s]+$|^[а-яёА-ЯЁ\s]+(?=[,;])[,;][а-яёА-ЯЁ\s]+$"
Local $sString = "Иванов Иван Иванович" & @CRLF & _
"Иванов Иван, Петров Петр" & @CRLF & _
"Иванов Иван; Петров Петр" & @CRLF & _
"Иванов Иван; Петров Петр; Иванов Иван" & @CRLF & _
"Иванов И. А." & @CRLF & _
"Иванов Иван, Петров Петр, Сидоров Сидор" & @CRLF & _
"Иванов Иван; Петров Петр; Иванов Иван" & @CRLF & _
"Иванов Иван; Петров Петр;" & @CRLF & _
"Иванов Иван; Петров Петр" & @CRLF & _
"Иванов Иван; Петров" & @CRLF & _
"б б б, ыва ываыв ыва"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")