$re = '/\ba\b\s\bleg[\w]+bb\b\s\b[\w]+\b/';
$str = 'This is grappa legaobb duh dang...
That is a legobatmanbb cave hahaha';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);