re = /\ba\b\s\bleg[\w]+bb\b\s\b[\w]+\b/
str = 'This is grappa legaobb duh dang...
That is a legobatmanbb cave hahaha'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end