// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\ba\b\s\bleg[\w]+bb\b\s\b[\w]+\b").unwrap();
let string = "This is grappa legaobb duh dang...
That is a legobatmanbb cave hahaha";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}