// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:http?:\/\/|https?:\/\/)?(?:www\.)?dribbble\.com\/(?:\/*)([\w\-\.]*)").unwrap();
let string = "https://www.dribbble.com/epiccoders?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name
http://dribbble.com/name/";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}