using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"delete_flag[]=[]0";
string input = @"delete_flag = 0";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}