package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`delete_flag[]=[]0`)
var str = `delete_flag = 0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}