$re = '/&\w{0,}?;/';
$str = 'Os ser­viços do Pla­no 1 da Assis­tência';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);